Jump to content

Welcome to OZx Forum

Welcome to OZx Forum guest,

Wouldn't it be nice if I would call you by your name or nickname of your choice ? 

Like most online communities you must register to post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of OZx Forum by signing in or creating an account.

  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members.

  • 0
aeronauta

OZx P3D Libraries Open Beta *** UPDATED 18/01/2018 ********

Question

78 answers to this question

Recommended Posts

  • 0

No problems Jorge, I did grab that update. For the most part, everything is pretty much intact as far as I can tell (across VIC, TAS, NT and SA). The standalone (not embedded within OZx v3-3.5), such as Coober Pedy, Broken Hill, Devonport, Flukey's NT fields, Stawell all seem to be fine... I got through most of SA today and things are looking good apart from the very occasional missing object.

It is a shame to think that ORBX AU V2 will probably make OZx scenery a thing of the past... There are some real beauties (almost ORBX freeware standard) amongst the mix though that I hope will stand the test of time, at least for the next few years.

Maybe at some stage, it'll be a matter of picking those ones out and seeing what can be done to keep them going?....

Share this post


Link to post
Share on other sites
  • 0

As far as I understand from Holger Sandmann's posting on a coming Orbx Australia V2 there will not be a "total rebuilding". There should be a great chance to use the fantastic OZx sceneries furthermore (hopefully)

Please read here:

FTX AU incorrect inland water textures in P3Dv4

Posting #17

Share this post


Link to post
Share on other sites
  • 0
On 25.11.2017 at 4:16 PM, jeansy said:

The 3 sisters in Katoomba are from the orbx libraries  not OZx, they are a part of FTX AU or the old FTX blue region

I'm pretty sure that this is not the case, because the early FTX AU didn't place any new objects, it was just a replacement for textures, vector and landclass data. PNW was the first region that had custom objects and enhanced default airports. I'm pretty sure that Katoomba/YKAT doesn't even exist in default FSX / P3D nor in FTX AU. I bought FTX AU a few months after a trip to Australia, and I remember that I wanted to know how Katoomba looked in the simulator compared to the real life photos I took there. And I was disappointed that the airfield didn't even exist. That's why I was happy to find that one of the OZx packages included YKAT, and I did my first OZx flight from there to check out the Three Sisters and if I'm not mistaken they were modeled as a 3D object in FSX but disappeared when I switched to P3D. Maybe one of the developers could chime in and shed some light on this. 

Share this post


Link to post
Share on other sites
  • 0

Fabs79 I removed OZx from FSX and the model of the 3 sisters is still there , cannot be OZx..

don't know where it is coming from , have a few checks but cannot find the file..check with ORBX and ensure they put it on in Australia V2...

I found that it is in FTXAU25_Scenery ORBX_Katoomba_Three_Sisters_PLC.bgl ,  ORBX_3sisters.bgl  and three .bmp files in the texture folder...

Jorge

Share this post


Link to post
Share on other sites
  • 0
14 hours ago, Fabs79 said:

I'm pretty sure that this is not the case, because the early FTX AU didn't place any new objects, it was just a replacement for textures, vector and landclass data. PNW was the first region that had custom objects and enhanced default airports. I'm pretty sure that Katoomba/YKAT doesn't even exist in default FSX / P3D nor in FTX AU. I bought FTX AU a few months after a trip to Australia, and I remember that I wanted to know how Katoomba looked in the simulator compared to the real life photos I took there. And I was disappointed that the airfield didn't even exist. That's why I was happy to find that one of the OZx packages included YKAT, and I did my first OZx flight from there to check out the Three Sisters and if I'm not mistaken they were modeled as a 3D object in FSX but disappeared when I switched to P3D. Maybe one of the developers could chime in and shed some light on this. 

Im more than pretty sure they are and I can bet my left nut on it, as Im from blue mtns and i can confirm it was introduced in FTX blue well  before OZX made any local airfields,

ORBX even made several posts on their forums regarding the introduction the 3 sisters and even posted preview images. ORBX regions dont only contain textures they also contain objects like the sydney harbour bridge  etc, etc there are a lot of us that where here before the days OZX started and before FTX started

as Jorge made the effort to confirm it, it maybe a case of you needing to delete the Orbx libs and re downloading them or raising a support post with them as its their object or ensuring that the object flow 2 is activated in the addons.xml

Share this post


Link to post
Share on other sites
  • 0
On 1.12.2017 at 4:41 AM, aeronauta said:

With only two or three people reporting problems this work will take some 5 years and after ORBX AU V2 a waste of time , might as well give up and enjoy flying a bit more...

I think time is on your side, Jorge: I personally have just moved to p3d and will try too install my beloved OZx world into it now. You can be sure I´ll communicate this in the orbx world - and it is a good season to fly around in OZx currently!

Am I right I just need to install the new libraries and then take all the "old" installers from OZx 3.0 to 3.5?

Share this post


Link to post
Share on other sites
  • 0

I answered to your Wagin post , but yes all is required is , install all of OZx  as per normal into P3D then replace the OZx_Lib with the P3D one.

Jorge

Share this post


Link to post
Share on other sites
  • 0

Gosh!

Thanks so very much Jorge. This is truly wonderful! You have given the community a great gift.

Is it ok to publicize this so that you have more "users/testers"?

Mike MacKuen

Share this post


Link to post
Share on other sites
  • 0

Hey Jorge @aeronauta,

Are you using OZx in the root folder of P3D or in the external Add-on file with add-on .xml?

Windows 10 completely crashed on me after a failed update and resulted in all applications being removed with a fresh install of windows 10... Only personal files and documents were saved so all my add-ons using add-on .xml were saved and ready to go once I got P3D installed again. I'm looking at if it's possible to use OZx via the add-on .xml so that I don't lose it all if anything goes wrong in the future...

Andrew 

Share this post


Link to post
Share on other sites
  • 0

Andrew , yes all my add ons are installed with the package add on way , you can install OZx and then using the folders create your p[ackage or add-on xml and done..

 

Jorge

Share this post


Link to post
Share on other sites
  • 0

Well no wonder , that xml is (with respect ) a mess!!...

first there is no such a category as ORBX (God forbid!!) ..

Create a folder OZx in C:\Users\YOUR_ID\Documents\Prepar3D v4 Add-ons

Now if in this folderyou place the two OZx main folders : OZx_AUS and OZx_Lib , the effects folder and the scenery one that has inside a world folder and inside a scenery one. next to them the add-on.xml file

 The add-on.xml should be like this

<?xml version="1.0" encoding="utf-8"?>
<SimBase.Document Type="AddOnXml" version="3,3" id="add-on">
  <AddOn.Name>OZx_AU</AddOn.Name>
  <AddOn.Description>OZX AU</AddOn.Description>
  <AddOn.Component>
    <Category>Scenery</Category>
    <Path>OZx_AUS</Path>
    <Name>OZx_AUS</Name>
    <Layer>9999</Layer>
  </AddOn.Component>
  <AddOn.Component>
    <Category>Scenery</Category>
    <Path>OZx_LIB</Path>
    <Name>OZx_LIB</Name>
    <Layer>9998</Layer>
  </AddOn.Component>

  <AddOn.Component>
    <Category>Scenery</Category>
    <Path>Scenery\World</Path>
    <Name>OZx_World</Name>
    <Layer>3</Layer>
  </AddOn.Component>

 <AddOn.Component>
    <Category>Effects</Category>
    <Path>Effects</Path>
    <Name>OZx_Effects</Name>
  </AddOn.Component>

</SimBase.Document>

 

Use Notepad++ to edit as the default notepad sometimes changes the format.

This is my OZx install in V4.1 (see pic) the bat file is there because I use the Add-on package ethod and it requires to execute a command line.

Let me know how you go , I can give you the full XML I use ...

 

Jorge

ozx.JPG

Share this post


Link to post
Share on other sites
  • 0

Haha, yeah, I'm just going off how other Add-on .xmls look. But no doubt, scenery is a little more complex.

That is one heck of an add-on .xml! I would never have come close to creating something like that ^_^

I can't recall what version of OZx installer the ORBX folder came from but it was 100% installed by one of the 3.0-3.5 OZx installers, and destined to go in the ORBX folder in the P3D root. It has a scripts folder with a windows batch file inside named 'AddSceneryLibEntries' and also a .cfg file named 'Scenerylib_!OZx'

What I did initially was made an OZx folder inside C:\Users\YOUR_ID\Documents\Prepar3D v4 Add-ons

From OZx 3.0-3.5, each installer was directed to that OZx folder inside     ^ Prepar3D v4 Add-ons

Your instructions sound straightforward, OZx_AUS and OZx_Lib go inside OZx, and the Effects and Scenery go with them alongside the Add-on .xml. However, inside that Scenery file is /Global/Texture/ rather than World/Scenery.

Attached is a screenshot of what the installers put inside the C:\Users\YOUR_ID\Documents\Prepar3D v4 Add-ons\OZx

Do I just forget about those other files and just keep the AUS and LIB?

 

Andrew

 

 

 

 

2018-01-03_19-11-22.png

Share this post


Link to post
Share on other sites
  • 0

I've got my add-on .xml looking like what you posted previously. Files are in place but nothing is showing up in P3D. P3D read the add-on .xml and I approved it to be used, but as I said nothing of OZx in sim...

I'll get to having a read through the SDK content at some stage, had a glance last night but need a more concerted effort and time to go through it and relate it to my add-on file and add-ons.

Any chance of getting the full add-on .xml and seeing if that works?

Is there anything in the works to bring everything OZx into one installer or would there be too many man hours involved and not enough demand?  

Thankyou for the help Jorge, really appreciate it!

 

 

Andrew

Share this post


Link to post
Share on other sites
  • 0

as it is all is good , the only thing I can suggest is that as you are using Notepad the file encoding is being corrupted.

 Get Notepd++ (free) , then edit tthe .xml , at the bottom should say UTF-8-BOM  , to change at the top menu select Encoding and convert to UTF-8-BOM..save and try.

Jorge

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, aeronauta said:

Which airports, please ..

Jorge

It’s scenery items I had previously placed with IS in Scotland. I’ll check a strip in AU and let you know later. Cub and orange traffic cones showing just not the gables and white conical cones. More later

 

Share this post


Link to post
Share on other sites
  • 0

Hi Jorge

Just getting back into simming and have switched over to P3D so I may be a little confused.

I have read the entire thread but I am unable to locate the add-on.xml file 

Have placed everything in the folder described above.

now I cannot get it to activate in P3D

Thanks in Advance

Peter

Share this post


Link to post
Share on other sites
  • 0

Here is the add-on.xml file (it was nowhere!!) , I made it as the sample above , if you place it in the folder next to the other files , restart the Sim and done...

Jorge

add-on.xml

 

@bruce Ok will see..thank you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×