FSX Multiplayer Direct Connection

15 posts in this topic

Posted (edited)

Hi OZx, ** This post was edited after advice from Jorge (Aeronauta) and comments from the kind OZx community **

I would like to host and participate in multi-player over the Internet with one or more friends and acquaintances. So, how do I do it?

I understand we are limited to "Local network (LAN)" option, and there are some prerequisites that need attending to before a successful and effective connection can be established with another player.

Assuming my friends and acquaintances are not connected directly to my LAN. I guess, connection is a bit simpler If they are directly connected.

Also, that you have an active Firewall on your computer and router.

So, what are these prerequisites?

  1. Working Internet connection to an ISP. logik.png
  2. Correctly configured computer and router Firewall "Ports". Edit ** Required ONLY if you want to Host a Multi-Player session. ** hmm.png
  3. Correctly identified IP address. hmm.png

Items 2 and 3 are the hard ones! Anyhow, from my research I've established the following...

Computer and router Firewall "Ports" Edit ** if you want to Host a Multi-Player session **

There are specific Firewall Ports that need to be "open" for communication to the Internet.

My router is a iiNet Bob2 connected to my ISP iinet. Edit ** and it has preset "Port Forwarding" for Microsofts Flight Simulator X. I've selected these presets and **

I also disable my Kaspersky antivirus software and firewall before using FSX.

In addition, I understand my computers IP address must be "static" on my LAN to successfully configure the ports.

Edit ** There are three is one port forwarding (opening) rule for Microsoft's Flight Simulator X and the range of ports needed to forward is dependent on the FSX MULTIPLAYER Network settings! You can find and change these port values.

How to find port values

  1. At the bottom of the "MULTIPLAYER Sign in to GameSpy or Lan" screen
    > Select the "Network settings..." button.
  2. At the "MULTIPLAYER Change network settings" screen
    > Enter the "Port range" [beginning] - [Ending].
    > Default FSX values of [6112]-[6122] are recommended unless they conflict with another application!
  • Inbound port = 2300-2400,
    Type = UDP,
    Private IP address = "my PC's IP address",
    Private port = 2300-2400
  • Inbound port = 6073,
    Type = UDP,
    Private IP address = "my PC's IP address",
    Private port = 6073
  • Inbound port = 23456,
    Type = UDP,
    Private IP address = "my PC's IP address",
    Private port = 23456

Therefore, I've updated my Firewall port forwarding to only one rule and deleted all others related to FSX;

  • Inbound port = 6112-6122,
    Type = UDP,
    Private IP address = "my PC's IP address",
    Private port = 6112-6122 **

IP address - Edit ** of session Host to be given to players Joining the session **

Note: This is not the IP address set within my router and allocated to my computer as identified with the "ipconfig" command - if you're aware of the windows command line function. It's the IP address as seen from the internet!

Apparently it's a simple process to identify the correct external IP address.

  • Using a web browser, enter a search "What's my IP Address".
    In Google above all search results, it responds with "Your public IP address is nnn.nnn.nnn.nnn", where I've replaced my actual IP address digits with an "n" for security reasons.
  • Alternatively, by logging on to my ADSL Modem Router I can see in "ADSL Setting:" a value for
    "3. my WAN IP address is:"
    Which is the same as the Google result!

Hosting a FSX Multiplayer Direct Connection

Okay, now that I've got the prerequisites accounted for, I just need to start a hosting session that my friends can connect to.

  1. Edit ** Communicate my External IP address to my friends and acquaintances whom I want to invite. **
  2. Start FSX and show the opening screen.
    Note: If you have the General Settings option "Show opening screen" de-selected, then you start at your default flight. Select "End flight" to return to the Opening Screen.
  3. At the Opening Screen:
    > Select "MULTIPLAYER" from the options list on the left.
  4. At the "MULTIPLAYER Sign in to GameSpy or Lan" screen there are two options (funnily enough called) Internet (GameSpy) and Local network (LAN).
    Note: Resources available have pointed out that the GameSpy connection method is no longer available.
    > Select the "Local network (LAN)" option.
    > Enter a "Player name".
    > Select the "Network Settings" button (Here I'll disable the client voice communication facility, apparently it is an efficient system. I'll use TeamSpeak instead... More on that later perhaps.)
    > Select the "SIGN IN" button.
  5. At the "MULTIPLAYER - Choose a session to join or host a session" screen:
    > Select the "Host a Session..." button.
  6. At the "MULTIPLAYER - Provide information for your session" screen:
    > Enter "Session information (appears in lobby)" as required.
    > Select "Make this session visible to everyone."
    > Select "On your Local Area Network (LAN)
    > Select the "NEXT" button
  7. At the "MULTIPLAYER - Choose session conditions" screen:
    > Enter and select the required conditions.
    > Select the "NEXT" button
  8. At the "MULTIPLAYER - Choose host options" screen:
    > Enter and select required options. (Review "Advanced Options" as well.)
    > Select the "NEXT" button
  9. A message "Connecting...", then the "Briefing Room - Review your session" screen is displayed:
    You can wait for other players to join or...
    > Select the "FLY NOW" button.

How to join a FSX Multiplayer Direct Connection

Edit ** Not having actually done this myself, ** I understand it goes like this...

  1. Follow steps 1 - 3 for the Hosting a FSX Multiplayer Direct Connection, then;
  2. At the "MULTIPLAYER - Choose a session to join or host a session" screen:
    > Select the "Connect Directly..." button.
  3. At the "MULTIPLAYER - Connect directly to IP Address" screen:
    > Enter the IP address as previously informed by the host.
    > Select the "FIND SESSIONS" button.
  4. A few messages, then the "MULTIPLAYER - Choose your session options" is displayed.
    > Update the options as required.
    > Select the "OK" button.
  5. At the "Briefing Room - Review your session" screen, players in the session are displayed:
    > Select the "JOIN SESSION" button

Details of what options to select in each of the screens mentioned above are available in the FSX learning centre as well as on the Internet. One resource I found very useful is the Mutley's Hangar guide to Multiplay In FSX.

I am experimenting with this at the moment, so I'll update this post as I discover anything interesting and critical to making it work. pilot.gif

Regards,

Wayne

Edited by expooz

Share this post


Link to post
Share on other sites

Posted

I,m sure Jorge (Aeronauta) our redident whizz on MP, will cast

his beady eyes over your post.

But I think you have a pretty good handle on it.

We are regularly getting up to 8-10 in our Friday night sessions, which I host.

My main issue was getting my modem/router port forwarding sorted out.

But a few minutes with Jorge on Teamspeak, soon had it sorted.

Cheers

TonyM

Share this post


Link to post
Share on other sites

Posted

I've got my ports forwarded and had a successful MP flight with Misha, but I had 10 ports forwarded.

6667 TCP
3783 TCP
27900 TCP
28900 TCP
29900 to 29901 TCP
13139 BOTH TCP and UDP
6515 BOTH TCP and UDP
6500 TCP
2300 to 2400 UDP
23456 UDP
6073 UDP
6112 to 6122 UDP
80 TCP

I don't know if I overdid it or not! :)

Share this post


Link to post
Share on other sites

Posted

Clem,

I only have 6112-6122 open.

No issues, had 10 online last night.

Not sure what the other ports are designed to allow.

cheers

TonyM

Share this post


Link to post
Share on other sites

Posted

Wayne, all of your settings are OK, but... the only ports you need to forward and allow through the modem and the firewall are 6112-6122.

I dont know why all others need forwarding as they are not used by fsx.

I have one more allowed for P3D (6037), but that is another thing...

regards Jorge

Share this post


Link to post
Share on other sites

Posted (edited)

Wayne, all of your settings are OK, but... the only ports you need to forward and allow through the modem and the firewall are 6112-6122.

I dont know why all others need forwarding as they are not used by fsx.

I have one more allowed for P3D (6037), but that is another thing...

regards Jorge

Thank you all for your responses.

Hopefully, this post will encourage other to try multiplayer as well. I know that some folk have difficulty with the technology, but are very passionate about our "interest" in flight simulation.

One more thing, is it absolutely necessary to "forward" the ports on the modem/router, What is the consequence if you don't?

Is it necessary only if your hosting?

And if your just joing a MultiPlayer (MP) session, then it's far simpler?

**Edit**

Just thought of another issue I noted today while in a MP session.

My FPS rate was dramatically reduced when in full screen mode, but normal in windowed mode. Any ideas why this would be happening?

**

Cheers

Wayne

Edited by expooz

Share this post


Link to post
Share on other sites

Posted

I believe if you don't forward the ports, it will not connect.

As for the frames, some users report they get better frames in windowed, and some in full screen. Nobody knows why it happens, probably one of those unique things that FSX specialises in doing. For example, I once had better frames in windowed, but after a reinstall, I got better frames in full screen.

Hope this helps

Share this post


Link to post
Share on other sites

Posted

Wayne,

I get better FPS in full screen

I reckon no two systems run the same, just do what gives you

smoothest result.

BTW we always lock our FPS to around 25 when in multiplayer,

Helps those with lower spec machines

Cheers

TonyM

Share this post


Link to post
Share on other sites

Posted

Wayne you only need to forward ports if you are Hosting...

Jorge

Share this post


Link to post
Share on other sites

Posted

I've got my ports forwarded and had a successful MP flight with Misha, but I had 10 ports forwarded.

6667 TCP

3783 TCP

27900 TCP

28900 TCP

29900 to 29901 TCP

13139 BOTH TCP and UDP

6515 BOTH TCP and UDP

6500 TCP

2300 to 2400 UDP

23456 UDP

6073 UDP

6112 to 6122 UDP

80 TCP

I don't know if I overdid it or not! smile.png

Clem, I think you have!

E.G. TCP port 80 is for HTTP so unless you are running a web sever at home there would be no need to forward this.

It would not be wise to have ports opened up unless there is a known need to have it open as it can leave you vunerable to trojans and port scanners looking for security holes.

A couple of web sites that will help in identifying port usage :-

http://en.wikipedia.org/wiki/List_of_TCP_and_UDP_port_numbers

http://www.speedguide.net/ports.php

Share this post


Link to post
Share on other sites

Posted (edited)

Hi everyone,

For some time now I have been happily joining my friend's multisession, but have wanted to sort out how I could host a session.
So I find this thread most interesting, but as yet we've not been able to get my PC to host a session.
I run Windows 7 Pro on a quad machine running 8Gb memory & several hard drives.
FSX is installed (& runs quite happily) on another HD than C: drive.
I have an iinet Bob Lite Modem. iinet is my ISP provider (over an NBN connection, here in Coffs Harbour NSW Australia).
I run both the PC & laptop as wireless connection/s through the modem.

I have set up the modem's Port Forwarding table with just 6112-6122, as per this thread's settings. (have also tried that long list except port 80).
I saved the modem setting & it 'remembered' it.
Am I missing something?. ie you say I must 'forward' the port/s?. I thought that that was what this setting was doing??.
And I am unsure of how to go about checking my firwewall settings?. I run the default MS firewall.

So far, I still cannot host a session. My friend can ping my external address ok (& of course he should; as I've been joining his multisessions for several months now).
But for the life of me, I cannot see what's stopping me from hosting a session?.

Any assistance greatly apreciated :well::)

kind regards,

Noel Brettoner

Edited by nbrettoner

Share this post


Link to post
Share on other sites

Posted

Hi Noel,

I've just had this same problem.

So you have created the open ports entry which you would have named. Net gear calls it a service which I named FSX.

But I forgot to allow this service through the firewall.

So first check what you have called the open ports entry and then allow that entry for incoming through the firewall.

Share this post


Link to post
Share on other sites

Posted (edited)

Hi Noel,

I've just had this same problem.

So you have created the open ports entry which you would have named. Net gear calls it a service which I named FSX.

But I forgot to allow this service through the firewall.

So first check what you have called the open ports entry and then allow that entry for incoming through the firewall.

Hi TreeTops,

Thanks for your quick response :)

I'd attach a screengrab here but aparently disallowed?.

Anyway, in the iinet Bob Lite modem under Port Forwarding I've entered:-

Enable Description Wan Interface Inbound port Type Private IP address Private port

tick FSX ipoe_eth3/eth3 6112-6122 UDP 10.*.*.* (my internal PC address) 6112-6122

I suspect that "Wan Interface" might be a problem, as I utilize the wireless capability of the modem. ie not ethernet cable.

If I should change this, my options are:-

pppoe_atm0/ppp0

pppoe_usb3g/ppp7

Any further thoughts?

Who could I ask?.

My actual Microsoft firewall is set to allow FSX. Do I need to check somewhere else here in the modem?I really apprteciate the help here :)

Edited by nbrettoner

Share this post


Link to post
Share on other sites

Posted

disregard the Microsoft firewall. that is on your pc.

there should be a firewall function in your router to look for.

Share this post


Link to post
Share on other sites

Posted

disregard the Microsoft firewall. that is on your pc.

there should be a firewall function in your router to look for.

Hi TreeTops,

I found the Firewall Section in the modem.

One of the three sections there is the Demilitarized Zone:-

If you have a local client PC that cannot run an Internet application properly from behind the NAT firewall, then you can open the client up to unrestricted two-way Internet access by defining a Virtual DMZ Host.

1. Enable DMZ: Enable Disable

2. Multiple PCs can be exposed to the Internet for two-way communications e.g. Internet gaming, video conferencing, or VPN connections. To use the DMZ, you must set a static IP address for that PC.

Public IP Address Client PC IP Address 1. 203.214.78.13 10.1.1.

I noticed that the Client PC IP Address was set at 10.1.1.0, so I have changed that to my actual internal PC address. As per Port Forwarding section.

Hopefully I'll get to try this out tomorrow. If you can 'PM' me on this forum I could give you my email address etc.

Once again thankyou for your valued help :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now